Renault Forums :: Independent Renault forum - View Single Post - Renault Clio 2 - Speedo Not Working*FIXED*

View Single Post
post #1 of (permalink) Old 13th November 2006 Thread Starter
Junior Member
Join Date: Nov 2006
Posts: 12
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 2 Times in 1 Post
Renault Clio 2 - Speedo Not Working*FIXED*

Hello to Everyone on the forum,
My wife has a 1998 Clio 1.2RN, the newish shaped one (S reg). We went to Wales (from Kent) this weekend and halfway up the M40 the speedo went from reading 70 to 0. After about 5 mins of no reading a warning light came on the dash that looks like one of those life support machine readouts?? Then after another 10 mins the speedo read ok again and the warning light went out. This has happened on and off all weekend with the speedo and warning light (speedo zero, light on and vice versa) coming on and off with anything from 2 mins to an hour between changes. Everything else on the car works perfectly and it drove to Wales and back with this going on/off without a hitch. In Wales I took both front wheels off but couldn't see a sensor or cable or anything that I thought maybe loose or dirty or something. Could anybody suggest what could be up that maybe I could fix myself.
Thanks in advance for any help,
Currently in bigginhillsteve's garage:
2003 Laguna 1.9 DCi
bigginhillsteve is offline  
The Following 2 Users Say Thank You to bigginhillsteve For This Useful Post:
Bob CCerinmax3 (8th June 2012), philip hardman (29th June 2011)
  5 Lastest Threads by bigginhillsteve
Thread Forum Last Poster Replies Views Last Post
Laguna ABS fault - help needed please.... Wheels & tyres Nish 1 2193 31st March 2011 05:42 PM
Help needed with loud clunking noise Wheels & tyres goods 4 3220 2nd August 2010 08:05 PM
Laguna revs drop while coasting..... Engines tazuk01 7 2636 3rd May 2010 10:51 AM
Really need some urgent help with Laguna problem... Engines bigginhillsteve 7 2006 28th April 2010 09:02 PM
Replacing turbo in a Laguna questions.... Engines bigginhillsteve 3 1963 25th April 2010 09:31 PM
For the best viewing experience please update your browser to Google Chrome