Renault Forums :: Independent Renault forum - View Single Post - Renault Clio - Electronics - Immobiliser issues

View Single Post
post #40 of (permalink) Old 30th August 2013
Junior Member
Join Date: Feb 2013
Posts: 11
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 1 Time in 1 Post
Re: Renault Clio - Electronics - Immobiliser issues

I had problems starting my Clio 2003 1.5dci for a looong time. First it would take short time, few times turning key down&up til it started until it developed in huge problem where I'd wait up to 15 minutes on parking lot to turn it on.

Since I've visited countless mechanics including authorized Renault motors one mechanic that owned Clio previously fixed it by changing one relay under the hood and as well as changing one socket where a smaller fuse goes also under the hood (right next to the car battery) because he said the socket got rusty and was loosing electric contact.

However, a lot of mechanics told me it was they key problem and new chip for the key had to be bought (which was not the case for me). And also one mechanic also told me car security system had to be changed (key socket lock under the steering wheel) because car wouldn't turn on due to nonrecognition of the key.
Currently in icecoldvedo's garage:
2003 Renault Clio II 1.5dCi
icecoldvedo is offline  
The Following User Says Thank You to icecoldvedo For This Useful Post:
Andrew Capp (20th October 2013)
For the best viewing experience please update your browser to Google Chrome