Renault Laguna I - Phase 1 - Electronics - How to troubleshoot Central Locking ( estate ) - Renault Forums :: Independent Renault forum

LinkBack Thread Tools Display Modes
post #1 of 20 (permalink) Old 31st August 2005 Thread Starter
Join Date: Aug 2005
Posts: 52
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up Renault Laguna I - Phase 1 - Electronics - How to troubleshoot Central Locking ( estate )

I have recently purchased a 1999 Laguna Estate. It has had two previous owners however it remains in very good condition. The car is a right hand drive as I live in the north of Sweden (where the temperature fluctuates between -10 and -20 from November until April).

I purchased the car with central locking and seat heating problems, negotiating the price down 10,000 kronor (£750). Firstly the remotes did not work and the guy I bought it from said that the Volvo dealer (Who handle Renault in Sweden) looked at the central locking and advised him to buy two new keys at a cost of 500 Kronor (£37) each. Upon inspection the remote batteries were in upside down in both keys. I purchased 4 new batteries and hey presto central locking now works from the remote.

I have however some questions. My user manual is in Swedish and as I am only learning the language I cannot fully understand what should do what. I am hoping that someone in this forum can help.

My questions are as follows;

1. When manually unlocking and locking the car from the drivers door should all other doors open and close also? Therefore, does the key lock control the other locks or are they controlled by the central locking button next to the hand brake? Or are they controlled by the remote, the manual key and the console button?

2. The rear door locks and unlocks by using the remote or the central locking button next to the hand brake however, the manual lock will not work when I insert the key! It just spins both directions! Does anybody know what the problem is and how to remedy it?

3. When the back door is opened should the rear internal light come on? I assume that it should as in other cars. The light illuminates ok and I have tried the switch in different positions but it does not come on each time I open the door. Is it a broken pressure switch located somewhere around the door frame that I am missing or is it something else?

4. Lefthand indicators appear to be occasionally possessed. They will work fine for a couple of hours then when I indicate they will blink at twice the normal speed? Once they start to behave in this manner they will remain so until the car is parked for a long duration, say, overnight and they are right as rain the next day. The right hand side always remains constant at a normal speed. Does anyone know why this happens and how to prevent this?

5. The seat heating in the car does not work. I discovered a blown fuse when inspecting the car and surmised that it was a short circuit somewhere possibly in the element in one of the two front seats. The dash indicator flickers at half strength when I move about in the driver seat so this seems to confirm it. (I believe that the dash indicator when illuminated indicates the seat heating has been activated however, this will not activate until the internal temperature drops below 12 degrees C +/- 4 degrees.) I do not know if seat heating is standard in all 99' Laguna’s! Does anyone have any pointers on how to approach this particular problem. All the electrics are under the seat and very difficult to access. It may be necessary to remove the front seats to check the problem. Before I go to extremes someone may be aware of a simpler solution. Can anybody help?

6. I am missing a speaker cover from one of the front doors and the other is not in the best shape either. Can anyone tell me of any good online shops or other sites I could buy two new covers. (I may also want a metal grill between the rear storage and the back passenger to keep the dog in the back).

Lastly when I bought the car the small hubcap from the centre of the alloy wheels were not fitted. The previous owner had broken it. The tool is a special type with three pins to secure a single bolt into each wheel. Volvo quoted me 450 Kronor (£33) for a new one. I bought a packet of M8 hex bolts for 55 Kronor (£4) and they are perfect for the job.

Many thanks for your help.
Dark Jupiter is offline  
  5 Lastest Threads by Dark Jupiter
Thread Forum Last Poster Replies Views Last Post
Laguna I Phase II Heated seats Interiors bonedavid 1 1565 21st October 2006 01:07 PM
Wiring Additional Headlights Electronics Horatio 1 1631 21st October 2005 07:35 PM
Central locking affected by cold weather? Electronics Shaun wall 28 7931 17th October 2005 08:18 PM
Renault Laguna I - Phase 2 - Interiors - How to... Laguna geochr 6 9702 14th October 2005 09:30 PM
Can your floor mats look like new? Interiors Garvey69 3 1953 13th October 2005 10:45 PM
Sponsored Links
post #2 of 20 (permalink) Old 31st August 2005
Platinum member
Horatio's Avatar
Join Date: Jul 2005
Posts: 6,475
Nominated 0 Times in 7 Posts
Nominated TOTW/F/M Award(s): 8
Thanks: 0
Thanked 95 Times in 64 Posts
1) The lock barrel in the driver's door only locks and unlocks the driver's door. The central locking only operates from the remote or the button on the dash.

2) I had this on my driver's door, and the dealer's answer was a new lock. Chances are though, if you take the trim off the inside of the door, you'll find a linkage that's broken or just come adrift.

3) If the light is in the boot, then I'd expect it to come on when the boot is opened. It may be a 3 position switch on the light, with the switch needing to be left in the middle for it to work when the boot is opened.

4) Fast flashing on the indicators tells you that one of the bulbs isn't flashing. It normally means the front or rear main bulb - a dead wing repeater isn't usually enough to set it off. It could be a number of things, but the first thing I'd try is taking both bulbs out on that side, and giving the holders a good clean. Edit: Or (with thinking head on now) just wait for the fault, park up, and see which bulb isn't working. That's the culprit.

5) I'm not sure about heated seats. They certainly weren't standard across the range in the UK and neither of my RXE's had them.

6) In the UK, GSF (German, Swedish, French - formerly Andyspares I think) are usually pretty good on price, though I think they tend to concentrate on mechanical components rather than trim. They do international delivery, but don't ask me how much it'll cost.
Currently in Horatio's garage:
2010 Laguna III Initiale.
Horatio is offline  
post #3 of 20 (permalink) Old 31st August 2005 Thread Starter
Join Date: Aug 2005
Posts: 52
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Many thanks for the quick reply Horatio.

Its a relief to hear that #1 is not an issue.

In relation to #3 I have tried the switch in all its different positions and it will only illuminate when placed in the permanently on position. I thought that was some form of pressure switch around the door frame to control this but as yet I have had no success in locating one.

I will follow what you have suggested in #2 and #4.

#5 is an open issue and thanks for the link to the site in # 6.

If anyone has any experience with the above problems of rear door light and heated seats could you let me know your thoughts and/or solutions.

Dark Jupiter is offline  
post #4 of 20 (permalink) Old 5th September 2005
Diamond member
HD462's Avatar
Join Date: Aug 2005
Posts: 97
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
In relpy to number 3, I take it you mean what we call the tailgate, the door at the back that gives access to the boot space?

I've just had a look at mine and as you say there is a switch, off/auto/on. Mine was set to off when I got the car, so I switched it to the auto setting so it came on when you open the tailgate. Then I thought the reason why they might have it off. If you're like us then you might have the tailgate open some time, we use it for sitting in the boot area when out for the day, putting walking boots on, sitting when having a picnic etc, all things which could flatten the battery if the light was on the auto setting.

Anyway, getting back to the point, I've just had a look at mine, and providing you have the switch on the light set right it should open when the tailgate is opened. I've looked for the switch and it appears to be inside tha tailgate and is operated by the lock latching. If you try closing the lock with a screwdriver (don't close the boot while in this position), the light goes out. Pressing the boot lock relase button sets the lock back to open, and the light comes on.

So I'd say the light is working ok, it lights up when set to 'on', it looks like the switch on the tailgate lock is stuck in the off postion, and not releasing when the lock opens. You should be able to get at it if you take the trim panel off the inside of the tailgate, and maybe try freeing the switch with some penetrating oil (WD40 type thing). If not it sounds like a new switch might be needed (you maybe lucky and it's just a bad connection on the switch or a loose wire).

Currently in HD462's garage:
2000 Renault Laguna 1.9dti estate
HD462 is offline  
post #5 of 20 (permalink) Old 6th September 2005 Thread Starter
Join Date: Aug 2005
Posts: 52
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts

Many thanks for the advice. I have tried the light in the various positions and it will only come on in the "ON" position and is therefore totally independent of the door. I will remove the tailgate door and inspect the lock and associated light switching to see if I can remedy the problem.




Thanks for the advice with the indicators. I turned out to be a loose connection on the front right light. It was however, fortunate to inspect the bulbs as the orange coating was falling off on both front bulbs and necessitated a change. All is working as it should now.

I still have to remedy problems 2,3,5 & 6.

Dark Jupiter is offline  

central , electronics , estate , laguna , locking , phase , renault , troubleshoot

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome