Renault Laguna II - Phase 1 - Bodywork - Front Wipers - Page 3 - Renault Forums :: Independent Renault forum

LinkBack Thread Tools Display Modes
post #11 of 31 (permalink) Old 6th December 2005
Platinum member
SportTourer's Avatar
Join Date: Jul 2005
Posts: 2,710
Nominated 0 Times in 1 Post
TOTW/F/M Award(s): 0
Thanks: 10
Thanked 48 Times in 39 Posts
Originally Posted by bonerp
can changing wiper blades be that tough?!!?! I changed mine with bosch ones at halfords with no problem. Just used the original adapter.

Yep, that's what I did.

I think the problem is that other adaptors inc Bosch are not that easy to fit, that is why I used he original adaptor.

Currently in SportTourer's garage:
2010 Laguna III SportTourer Initiale Tom Tom.
SportTourer is offline  
Sponsored Links
post #12 of 31 (permalink) Old 6th February 2006
Diamond member
Join Date: Aug 2005
Posts: 128
Nominated 0 Times in 0 Posts
Nominated TOTW/F/M Award(s): 1
Thanks: 0
Thanked 0 Times in 0 Posts
I think the key thing here is that they're using Valeo replacement blades. With these, swapping the blades over is a piece of cake (as it should be) as they've got the large enough 'hole' for feeding the wiper arm through.

It's when you've got replacement blades from another manufacturer (e.g. Bosch) that you run into difficulties.
Currently in dkmulvey's garage:
'02 Renault Laguna II 1.9dCi Dynamique

Last edited by Laguna II Owner; 3rd April 2006 at 10:13 AM.
dkmulvey is offline  
post #13 of 31 (permalink) Old 3rd April 2006
A former user
Posts: n/a
Or if you buy Bosch - Use the adapters from the Valeo wipers..

My god that's the 3rd time its been said now..
post #14 of 31 (permalink) Old 12th November 2008
Junior Member
Paul1's Avatar
Join Date: Feb 2008
Posts: 26
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 1
Thanked 0 Times in 0 Posts
OK im having the same problem as everyone else (cant get old wiper blade off because the blade only moves about 60mm from windscreen).

I'm going to take to arm off.

Ive taken the arm nut off and have sprayed the spindle with wd40. im going the leave it overnight and try to remove it tomorrow.

I'll post again to let everyone know how I got on
Currently in Paul1's garage:
2001 Renault Laguna II 1.9 dCi
Paul1 is offline  
post #15 of 31 (permalink) Old 12th November 2008
Technical Supremo

Join Date: Feb 2007
Posts: 42,935
Nominated 16 Times in 67 Posts
Nominated TOTW/F/M Award(s): 28
Thanks: 371
Thanked 5,199 Times in 4,711 Posts
I have just fitted a new set of wiper rubbers to my Lag II without taking the arms off. Switched the wipers on - removed the keycard when the wipers where in the vertical position and was able to release the retaining clips - if changing the blades. A bit of a squeeze but it was managable.
Currently in madnoel10's garage:
Honda Civic 1.4l

Last edited by madnoel10; 20th November 2008 at 12:04 PM.
madnoel10 is offline  
The Following User Says Thank You to madnoel10 For This Useful Post:
db3oyh (18th November 2014)

bodywork , laguna , phase , renault , wipers

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome