Renault Laguna I - Phase 2 - Electronics - Horn location - Page 3 - Renault Forums :: Independent Renault forum

LinkBack Thread Tools Display Modes
post #11 of 12 (permalink) Old 13th July 2007
Technical Supremo

Join Date: Feb 2007
Posts: 42,935
Nominated 16 Times in 67 Posts
Nominated TOTW/F/M Award(s): 28
Thanks: 371
Thanked 5,199 Times in 4,711 Posts
Hi Scatz - maybe your motor supposed to have an undertray but somebody trashed it - I know they are a pain but don't be tempted to run your car without it. Without any protection there is a risk of small stones, etc getting flung up into the engine bay and damaging the auxillary belt which if fails can cause the timing belt to fail and then the engine is likely to get furbarred. I t happened to a neighbour of mine - he ended up needing a new engine and it wasn't a cheap. Yeh if you have a look round many garages you'll find loads of the darned things piled up somewhere - the manufacturers did fit them for a reason apart from reducing noise.
Currently in madnoel10's garage:
Honda Civic 1.4l
madnoel10 is offline  
Sponsored Links
post #12 of 12 (permalink) Old 13th July 2007
Platinum member
scatz's Avatar
Join Date: Sep 2006
Posts: 12,008
Nominated 0 Times in 4 Posts
Nominated TOTW/F/M Award(s): 5
Thanks: 59
Thanked 331 Times in 300 Posts
Thanks mad, but having had a look the noo, my Lag appears to have two smaller undertrays either side rather than one which reaches all the way across the engine bay. Obviously, the belts are protected by the drivers side undertray. There definately should not be one all the way across the engine bay as there are no places to fix it and there is also a piece of stiff plastic that is angled at 90 degrees to the road across the section where there is no undertray, pressumably a deflector of stones itself.

Currently in scatz's garage:
2004 Subaru Legacy GT Spec B, a 2013 2.0 TDCi Titanium X Sport S-Max and a 2001 Honda NSR125R
scatz is offline  

electronics , horn , laguna , location , phase , renault

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome