Renault Laguna II - Phase 1 - Engines - Spark Plug Type - 2.0 IDE Laguna 2002 - Page 4 - Renault Forums :: Independent Renault forum

LinkBack Thread Tools Display Modes
post #16 of 46 (permalink) Old 29th March 2006
Diamond member
Join Date: Mar 2006
Posts: 181
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
ide man


I have been looking into this
My car I believe was given an upgrade when it was serviced by renault on the injection software maybe a renault dealer mechanic on this forum site can comfirm .
Maybe Renault have got away with out a recall as I do have the same engine as you and I am not lying I presumed it was a recall as I did not have to pay for it .
Mushroom a member of this forum has also made mention of an upgrade for this engine . |Search under Ba baracusse or lumpy idle he seemed to have the same fault it was his oxygen to fuel mix cheap repair .
Its hard to be 100% correct without looking at your car myself ask the garage to do a live run with your vehicle .

Hope this has helped I still feel you have plenty of miles left in the engine and its just a sensor . Your mpg will rise if it is this problem .I got 38 mpg on a motorway run traveling to penrith doing between 70- 80mph not bad for a petrol engine long live the ide

ide man
Currently in ide man's garage:
03 laguna initiale 2ltr ide
ide man is offline  
Sponsored Links
post #17 of 46 (permalink) Old 29th March 2006
Platinum member
Horatio's Avatar
Join Date: Jul 2005
Posts: 6,475
Nominated 0 Times in 7 Posts
Nominated TOTW/F/M Award(s): 8
Thanks: 0
Thanked 95 Times in 64 Posts
My 2.0 IDE was definitely taken in for ECU reprogramming, and it was an official recall (I had the letter from Renault.) According to the bumf, it was for emissions related reasons.

After reprogramming, the car seemed to perform much better at high engine speeds than it had before (it used to have some hesitance between 6000rpm and the red-line that disappeared afterwards) but apart from that, it made no obvious difference.

It certainly didn't improve fuel economy, so I can't see how it would have improved emissions, unless the engine had been running rich or lean and feeding the wrong gases to the cat.
Currently in Horatio's garage:
2010 Laguna III Initiale.
Horatio is offline  
post #18 of 46 (permalink) Old 30th March 2006
Posts: n/a
Just confirmed with local dealer that car was reprogrammed (injection computer) in 2003 but strangely there is another meontion of injection computer in Nov 2004 after 90k miles. I've booked in for a diagnostic meanwhile i'll change the plugs (anyone know what the gap setting is?) so let's see what comes up.
Just to add to this dealer had it in for diagnostic and invoice said "eraze memory" will have to see if the fault goes!! Taking it for a blast tomorrow hope it behaves!!

Last edited by MIKE4369; 4th April 2006 at 06:53 PM.
post #19 of 46 (permalink) Old 5th April 2006
Posts: n/a
To ide man
Perhaps this is not the place to post this but here goes.
The fault showed up 3 times today despite the clip test and reset(?). I've checked to see correct plugs put in at last service (3k miles ago), i noticed that the one I took out of cylinder 1 was a bit sootybut that was not after a run, the service also included air filter(would a non Ren type cause a problem?). I suplied the oil Castrol high mileage (not a good choice so I've been told, may change it to Amsoil 5w-40)
What sensors should I be thinking of replacing if all else fails. The fault includes ESP but can't see the connection. Any advice gratefully recieved.
post #20 of 46 (permalink) Old 5th April 2006
Diamond member
Join Date: Mar 2006
Posts: 181
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts


Were you given the fault codes ??
I would only recommend genuine Renault parts on an engine which is so sensitive .
Trying to diagnose is hard without looking at it . If compression is good which it sound like it is if it goes like stink I would start with the tdc sensor which is cheap give it a clean ?A local garage will do this .
Have you checked and cleaned your idle valve ??
As this can cause your problem .
If you have had it into renault what have they done and how much have they charged .??
If you take it into a Reg vardy renault dealer for something minor they do a free health check on the vehicle .
They then tell you any faults and the cure and they also give you a quote for the work (well they did at the one in Harrogate ) I was very impressed .
As my air con had stopped working and I couldnt figure it out but within 10 minutes they had told me the problem which I then rectified myself .
But a word of warning all dealers are different .
Start with the sensors I have mentioned and I would have a word with Mushroom a forum member who I believe had your problem and this was to do with the air intake .
As for your esp system what is it doing ??

Thanks ide man
Currently in ide man's garage:
03 laguna initiale 2ltr ide
ide man is offline  

engines , ide , laguna , phase , plug , renault , spark , type

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome