Renault Forums :: Independent Renault forum - View Single Post - Renault Clio II - Electronics - TDC sensor

View Single Post
post #10 of (permalink) Old 19th October 2005
Junior Member
Join Date: Oct 2005
Posts: 5
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by theogeor
My wife's renault Clio (1.2 98/S 70K on the clock service regularly) started recently to misbehave. It stalls while you are going (usually when you decelerate) and you have no power. When you stop it either revs up at about 3000rpm or the engine stops completely (most often it stops) and it takes a bit of an effort to start it again. I though it might have been a fuel problem so I checked the fuel lines and I changed the fuel filter but problem still exist. Looking at the post it looks like it might be the TDC sensor as well. Before I replace it does anybody else had a similar problem ? Is it the right thing to do or shall I look at other things ?
I have a 2003 Clio dci 80. This started 'lurching' after coming off the accelerator and re-applying. e.g. cruising along the motorway in whatever gear, queue up-ahead so come off the gas, then start to accelerate again and it lurches forward. This has now been compounded by the fact that the engine completely cuts out. I have now managed to get it so that if I turn the engine off and back to the 'ignition' stage it will kick back into life again (can now all be done within 1 sec!) so that when I am going along the motorway I don't need to pull over.

I, too, have had the fuel lines checked; the fuel primer taken out of the equation in case it was dragging air, the car hooked up to a laptop to check all electronics etc etc.
Would this TDC thingy be on a diesel as well? Is that something to check? HELP!!! - Please can someone reply ASAP - it is booked into the Main Dealer in 2 weeks!
turnerr12 is offline  
For the best viewing experience please update your browser to Google Chrome