Renault Forums :: Independent Renault forum - View Single Post - Two problems: Knocking noise Believed from Engine Mount and Misfiring (Wiring Loom)

View Single Post
post #1 of (permalink) Old 28th November 2006 Thread Starter
Junior Member
Join Date: Nov 2006
Posts: 12
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Two problems: Knocking noise Believed from Engine Mount and Misfiring (Wiring Loom)

Hi All,

I'm new to these forums and am hoping someone can help.

1st . I had a severe knocking sound when I was applying the breaks. Ascertained Caliper sliders were worn and so the caliper carriers were replaced with part from brakers for 60.
2nd . The noise was massively reduced, but any sudden breaking caused another slight knocking sound A local garage believes it may be down to the engine mounts. Researching the net, the replacement / adjustment of the mounts doesn't appear to fix the problem ... anyone know what this may be/the solution?
3rd . When stationary my car used to often cut out and struggled to restart. Speaking to a Renault Specialist who run the computer through it established it was down to the wiring loom. The garage claims it is a common problem for the security box to the rear of the engine bay to cut through the wire. He reset the computers for now and the problem hasn't reocurred, but now there is a slight loss of revs momentarily when at higher speeds before regaining itself. Is the wiring loom a simple thing a novice could replace or is this just not the problem.

I am hoping to get these problems fixed so I can sell it. A
ny help would be greatly appreciated. Apart from the knocking noise and the occasional cutting out, its a great runner

Are there any local mechanics near Bedfordshire that could assist?

Thanks, Chris
Currently in Harry_Potter's garage:
Renault Clio 1.2 16V Dynamique (3dr)
Harry_Potter is offline  
  5 Lastest Threads by Harry_Potter
Thread Forum Last Poster Replies Views Last Post
How easy / How do you remove and replace wiring... Clio davesss 3 5378 23rd December 2006 11:22 AM
Clio 1.2 (2002) 16V Dynamique - Failing to start... Clio molar 3 2784 17th December 2006 08:39 PM
Renault Clio II - Electronics - Changing headlamp... Clio Brilec 6 13025 28th November 2006 01:26 PM
Two problems: Knocking noise Believed from Engine... Clio TazzyK 8 9927 28th November 2006 01:03 AM
For the best viewing experience please update your browser to Google Chrome