Renault Forums :: Independent Renault forum - View Single Post - Problems with a mk2 megane 2003 1.5 dci

View Single Post
post #1 of (permalink) Old 29th September 2013 Thread Starter
Junior Member
Join Date: Sep 2013
Posts: 20
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 2
Thanked 0 Times in 0 Posts
Problems with a mk2 megane 2003 1.5 dci

Hi everyone,

I recently bought a Megane at an excellent price however I took a risk as the car only had a weeks MOT left. Ive purchased the car so its safe to say theres no going back. First thing I did was take it to a local garage for a check up and prep for MOT. I got them to change a few parts such as cv boot, rear disks and pads which they said required changing. Ive also purchased all the filters, timing belt kit and oil so when it was going to pass the MOT I would get it serviced. The cars done 99k miles to date.

The cars failed the MOT....sigh. A few things are easy fixes such as windscreen washer providing insufficent fluid, top strut mount with bearing and other bits and pieces. Two things I am concerned about however. One is that the airbag light is on and the garage have said to me they will try to get it fixed. Ive read the forums in detail here and it could be as simple as the wires being loose under the seats? Anyone got any other ideas and the cost involved.

The other issue which is my primary concern is that theres a potentiol problem with the steering. The car says check steering on display and Ive noticed that sometimes when braking I get some vibration through the steering wheel. What could this possibly be? warped disks? Surely the mechanics would have spotted a problem when I asked them to check the car?

The garage have referred my car onto a specialist garage who specialise in steering matters. They will hook it up to a diagnostics machine and take it from there. Should I be worried at this stage? What sort of problems could cause this?

One other issue is the other day when I attempted to start the car it wouldnt start, the card key appeared to not work. The spare dosent work at all and the one I have seems to cause problems. It didnt detect the card then after 20 minutes of trying it worked! Again..Ive had a look on here and it could be that the card key needs repaired. A few sellers on ebay have their service advertised for only 20. Could I send the old one (the one that dosent work to be repaired) or should I send the working one?

Better still Im in Glasgow, if anyone can recommend anyone for the card key problem I would be greatful.

Thanks guys.
Currently in obayda1991's garage:
2003 Reanult Megane mk2 1.5 dci
obayda1991 is offline  
  5 Lastest Threads by obayda1991
Thread Forum Last Poster Replies Views Last Post
steering issue (Megane 2003) Steering and Suspension ste2425 6 1430 6th September 2014 03:54 PM
Megane 2003 1.5dci electrical issues! Electronics Nottnoc 5 1136 22nd June 2014 05:44 PM
Bacbox for megane Exhausts scatz 1 761 8th January 2014 03:31 PM
Wishbone 16mm or 18mm? Steering and Suspension TTT 1 850 8th January 2014 03:27 PM
Am I looking at the right parts? Wheels & tyres obayda1991 0 558 8th January 2014 03:20 PM
For the best viewing experience please update your browser to Google Chrome