Renault Forums :: Independent Renault forum - View Single Post - ABS sensor/ring

Thread: ABS sensor/ring
View Single Post
post #1 of (permalink) Old 10th October 2013 Thread Starter
Junior Member
Join Date: Sep 2013
Posts: 6
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
ABS sensor/ring


Got my car back from the garage after needing a new hub. I knew I had a problem with the brakes/abs before hand as the abs would grab at the wheels whilst I was breaking at low speed (only when the car first starts, once the car gets over 20mph the problem stops and doesn't come back on until the engine is turned off and left for a few minutes). The mechanic said I need to get new abs rings? and that I'll need a whole new driveshaft as they come in 'one'. Can anyone shed some light on this matter? I was looking at abs rings and can only find ones for the rear wheels. its a Megane II 1.6 53 plate

Currently in aidenmoore's garage:
2003 Renault Megane 1.6
aidenmoore is offline  
  5 Lastest Threads by aidenmoore
Thread Forum Last Poster Replies Views Last Post
ABS sensor/ring Brakes/Hubs Meganeman 2 1312 10th October 2013 08:53 PM
Megane mk2 NSF Hub HELP! Brakes/Hubs mender2002 3 1004 5th October 2013 04:09 PM
Knocking accelerator and rumble Wheels & tyres aidenmoore 0 659 3rd October 2013 08:46 PM
2003 Megane brake shudder low speed Wheels & tyres hondo 4 1131 7th September 2013 01:18 PM
For the best viewing experience please update your browser to Google Chrome