Renault Forums :: Independent Renault forum - View Single Post - Renault Laguna II - Phase 1 - Engines - 2.0 IDE engine problems !

View Single Post
post #114 of (permalink) Old 11th October 2013
Junior Member
Join Date: Oct 2010
Posts: 5
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 1
Thanked 0 Times in 0 Posts
Smile Re: Renault Laguna II - Phase 1 - Engines - 2.0 IDE engine problems !

Ok my 2 pence worth, Just did an ebay number on a 2003 34k yes Thirty four K miles 2.0 ide 310 Top speck too .All the lights on injector fault , safe mode !! etc. read the forums great stuff on there, it came with the old pump and a newer pump. The actuators on these 3 barrel pumps fail if dry killing the line pressure.well the newer pump had died turn the cam by hand if it has a tight spot throw it away.I killed the original pump pushing it over 3000 rpm before safe mode cut in. So Im Thinking fuel starvation changed the Tank low pressure pump a new high pressure pump (went to local Renault 10 days and 700) Right ) guy on Ebay selling new 94 bought it at 2:30 arrived at 9 am the next morning. Changed both pumps priming the high pressure before fitting .Boom all lights out been running for 3 weeks now. sorry i digress 10 mm spanner for the pump and a 12 mm for the fuel line out leave the low pressure feed in .remove the high pressure pump on the R/H cam end turn it by hand if it gets tight change it and look for low pressure probs. That's it just thought worth sharing.
Currently in mag23600's garage:
53 Nissan D22-03 Laguna 11-04triumph Tiger- 01 Saab 95 estste
mag23600 is offline  
For the best viewing experience please update your browser to Google Chrome