Common problem - breaks squealing - Page 6 - Renault Forums :: Independent Renault forum

LinkBack Thread Tools Display Modes
post #26 of 26 (permalink) Old 13th August 2015
Junior Member
Join Date: Apr 2013
Posts: 2
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Common problem - breaks squealing

I thought I was the only one!

Such a bad squeal from the brakes, made worse after installing brand new ferroco pads + discs (highest grade I could buy at trade counter)

I've previously tried copper slick but someone also suggested bleeding my brakes?

Undertaking the work myself due to lack of funds, will update if I find anything, but good to know I'm not the only one.
Currently in JWilks's garage:
2004 Megane 1.6
JWilks is offline  
Sponsored Links

breaks , common , problem , squealing

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome