Renault Forums :: Independent Renault forum - View Single Post - Issues...

Thread: Issues...
View Single Post
post #1 of (permalink) Old 19th December 2006 Thread Starter
Mad Stuntman
Junior Member
Mad Stuntman's Avatar
Join Date: Dec 2006
Posts: 3
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts

First of all I'd like to say Hi everone

Secondly, I've recently (2 days ago) bought myself a Laguna 2.0 RT estate and i love the car but for a few problems... (hence the help bit!) So i thought I'd ask you good people for advice

1 this afternoon the indicators packed up, Hazards work fine but just nothing at all from indicators. Checked fuse its ok and i know its not a lightbulb mass suicide cos hazards still work.

2 Speedo dosen't work

3 Passenger elec window goes down ok but EXTREMELY slow coming up (well it starts slow and gets faster as it gets nearer to the top)

Well thats the important ones, There are a few other things but nothing i cant fix with a universal adjuster. That said I hope this will be the start of a long and beautiful relationship (both on here and off) and thank you in advance for any help
Currently in Mad Stuntman's garage:
1997 Laguna 2.0(8V) RT Estate
Mad Stuntman is offline  
  5 Lastest Threads by Mad Stuntman
Thread Forum Last Poster Replies Views Last Post
Overcooling Heating & cooling madnoel10 7 1675 3rd January 2008 04:35 PM
Issues... Electronics scen1c 3 839 19th December 2006 05:55 PM
For the best viewing experience please update your browser to Google Chrome