Renault Forums :: Independent Renault forum - View Single Post - Does anyone have a Megane III that actually works?

View Single Post
post #1 of (permalink) Old 3rd December 2013 Thread Starter
Join Date: May 2013
Posts: 45
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 9
Thanked 2 Times in 2 Posts
Angry Does anyone have a Megane III that actually works?

Hi All,

A little bit of rant to start this post off.

I bought a Megane III from a car hyper market. It was a 2010 model (Privilege). Came with 30 days warranty.

Was a fairly decent price so thought I would go for it. (9000)

When driving it home that same day I had an Oil warning light come on, on the car.

Took it to Kwik-Fit because the oil was on 2 notches out of 6 on the led display. - paid for new oil .

About two weeks later the "Braking warning light" came on and I had to get the brakes replaced. (80% worn). - paid for them to be replaced

Whilst at the Renault garage for the "Braking warning light" they discovered an oil leak on the head gasket, it was fixed under warranty. - fixed under warranty.

I had 3 weeks of pleasant driving after this.

Then a hole developed in the carpet right next to the clutch, it was there from purchase but never got around to fixing it, got it fixed in Oct '13 - Non warranty job (250)

Next was the washer bottle, it was leaking water so I had nothing left when I needed it. - fixed under warranty.

Next was the window wipers, they hit each other sometimes when driving. - fixed under warranty.

Next was the boot carper, it was separating from the underneath like actually coming apart. - fixed under warranty.

Next was the gear leather it had a rip it in. - fixed under warranty.

and now finally today. - the UCH ( ECU ) thing has gone, awaiting a price the car is currently in bits in the garage. the indicators kept flashing when I switched the car on. probably going to be between - 400 and 800.

I just don't know what to do anymore. it's a 2010 car and it's got 30,000 miles on the clock.

So my question is am I just unlucky / not doing something right?

Why is my Megane such a waste of space???

Currently in 182344's garage:
Megane RS II 2.0T 225hp
182344 is offline  
  5 Lastest Threads by 182344
Thread Forum Last Poster Replies Views Last Post
Would someone take a photo on the location of... Electronics 182344 1 468 10th November 2014 09:09 PM
does a Megane 225 have a PCV valve where is it? Engines coup 9 1955 5th August 2014 03:26 PM
Megane 225 Smoking - Valve Stem / Piston Rings Engines coup 17 3038 5th August 2014 01:09 PM
Sony Aftermarket Radio + Amplifier (AMP REM?) Electronics 182344 0 632 21st May 2014 09:14 PM
Megane 225 Engine Cover Rubbers Engines 182344 3 1917 30th April 2014 02:06 PM
For the best viewing experience please update your browser to Google Chrome