Renault Forums :: Independent Renault forum - View Single Post - Laguna hatch handle

View Single Post
post #5 of (permalink) Old 12th January 2007
Platinum member
matt_dci's Avatar
Join Date: Apr 2006
Posts: 1,708
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 7 Times in 4 Posts
Send a message via MSN to matt_dci
Originally Posted by SportTourer View Post
Mattdci had the same problem the other day.

it is also a fairly common problem on Laguna II Sporttourer models pre 2003, less common on the hatchbacks. It is normally due to water ingress in the switch mechanism.

Prise out the mechanism,clean the contacts and spray with wd40 type stuff and you should be ok.

I think there are more details of how to get to the switch on the forum somewhere.
If you try a search, hopefully you will find the info.
I'm sorry, if I had the time I would search for you and post a link to the relevant thread.

I sure did!

But, unlike the estate's, it's not as easy to get to the lock workings from inside. I did'nt want to force my boot open and end up not being able to shut it again (car's parked in the road overnight!) so booked it into my local dealership.
They replaced the lock for 76. Did'nt think this was too bad a price, seeing as I probably would've ended up damaging something else or breaking the lock completely if I'd had a go

Currently in matt_dci's garage:
2008 Citroen Grand Picasso 1.6 VTR+ & 2009 '09' Merc Vito 109 CDi
matt_dci is offline  
For the best viewing experience please update your browser to Google Chrome