Renault Forums :: Independent Renault forum - View Single Post - Climate control panel slow to power on??

View Single Post
post #1 of (permalink) Old 17th January 2007 Thread Starter
Diamond member
carlbrown15's Avatar
Join Date: Nov 2006
Posts: 101
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 1 Time in 1 Post
Question Climate control panel slow to power on??

Just noticed that my climate control panel seems to be taking longer to power on when you get in and start the car. Initially back lit display no icons and no lights on buttons and it is taking about 30 secs to power up once you start the engine. Is this normal? (ie system check? and i'm paranoid about my cars electrics?) Or does it indicate that their is a problem?

And does this have anything to do with my outside air temp sensor not working properly? Does it send a feed to the climate control?

Thanks Carl
Currently in carlbrown15's garage:
2004 Renault Laguna II 1.9 dCi GT, 2010 Ford Fiesta Zetec 1.6 TDCi
carlbrown15 is offline  
  5 Lastest Threads by carlbrown15
Thread Forum Last Poster Replies Views Last Post
Laguna 2 1.9 dci throttle valve housing oil... Engines Andyt1 10 8049 21st September 2010 01:06 PM
Laguna II - How long did your front brakes last? Brakes/Hubs dirtyleeds 13 2685 12th September 2009 04:17 PM
Laguna II dci slow to start/fire Engines carlbrown15 3 1549 14th August 2009 02:05 AM
Sound Cards Computer Club carlbrown15 10 1819 4th March 2009 04:33 PM
Thule roof bar whistle Cars & motoring Rallysteve61 10 4909 9th February 2009 02:24 PM
For the best viewing experience please update your browser to Google Chrome