Renault Scenic II - Access the resistor pack in 5 mins. - Page 8 - Renault Forums :: Independent Renault forum

LinkBack Thread Tools Display Modes
post #36 of 367 (permalink) Old 20th October 2009
Junior Member
Join Date: Aug 2008
Posts: 2
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 1 Time in 1 Post
Scenic with Climate control

As i have found, if you have a scenic with automatic aircon or climate control, the process as detailled by Aahbarnes is slightly different. The "Resistor pack" is a different design but is in the same location . It is held in place by one fixing towards the front of the dash and a clip at the back . It has two green connectors . Once removed you will see it looks more like an Amplifier. with a heat sink. There are no resistors or thermal fuses in it and nothing that looks user repairable ( its all microchips and very small ones at that !). It is a little more expensive as well at 82 . If you wish to help prove that this part is at fault (as was mine - no Aircon or blower motor ) then taking the larger of the two green plugs from it ,12v connected to the Red and Black wires in it will operate the blower motor, so you can check it without disasembling the dash.
dpeel is offline  
The Following User Says Thank You to dpeel For This Useful Post:
pauld149 (28th January 2014)
Sponsored Links
post #37 of 367 (permalink) Old 24th October 2009
knownClone's Avatar
Join Date: Dec 2007
Posts: 375
Nominated 0 Times in 1 Post
TOTW/F/M Award(s): 0
Thanks: 3
Thanked 19 Times in 18 Posts
Thumbs up Resistor Pack SAAB/FIAT

My 9000 had only Full Speed when I bought it, so I looked in the scrappies to find another to swap.

I pulled 2, and they were burned out too....(very easy to get at - under the plastic scuttle cover, thankfully)

I found a Sciento with the RPack easy to spot (it sits in a section of ducting, after the fan but before the pipe goes into the bulkhead) and simply pulls out!
Araldited the whole shabang into the 'butchered' SAAB holder - not hard to do - and 'bodged' the push on connections (SAAB Large - FIAT smaller).

50p + glue.

Never flickered

... just thought I might give hope to ardent 50P 'bodgers'...

Currently in knownClone's garage:
Proton Savvy + [Worx] PugPartner
knownClone is offline  
post #38 of 367 (permalink) Old 12th November 2009
Junior Member
darren7303's Avatar
Join Date: Nov 2009
Posts: 3
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Hi all,

I have just bought a 2004 Scenic 1.9 with the same problem.

I tried last night to access the resistor pack throught the dash. I managed to remove the resistor but there isn't enough wire to pull it up to the dash as per the photos. Is the wiring clipped in somewhere or will I have to remove the dash?

darren7303 is offline  
post #39 of 367 (permalink) Old 13th November 2009
Junior Member
Join Date: Oct 2009
Posts: 1
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by aahbarnes View Post
There's another post somewhere waiting for approval.
Thanks very much for the pictures. I've just managed to replace the resistor pack and fit the modified loom to my Grand Scenic. You do need a thin arm to reach the resistor, and you need to cut the leads to the blower as the plug is not accessible. I managed to solder those. The leads on the new loom section are all the same colour so I matched them one at a time to the old plug positions. I connected those with screw strip connectors. The parts cost 96 from Renault. The blower works fine on all 4 speeds now. I just need to find out why the engine idles like a canal boat until I've covered about 20 miles and I'll have a very nice vehicle.
Currently in wanstead's garage:
2005 Grand Scenic 1.9DCi Privelege
wanstead is offline  
post #40 of 367 (permalink) Old 14th November 2009
Junior Member
Join Date: Nov 2009
Posts: 1
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
I have just picked up my resistor pack and new loom, I need some guidance as to how to connect the loom as the new loom is fitted with more wires than the original, if anyone could help it would be much appreciated
cragbot is offline  

access , mins , pack , renault , resistor , scenic

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome