Renault Forums :: Independent Renault forum - View Single Post - Clio (2001) 1.2 16v electrical problems

View Single Post
post #1 of (permalink) Old 8th November 2005 Thread Starter
Junior Member
Join Date: Nov 2005
Posts: 3
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Clio (2001) 1.2 16v electrical problems

hi there... I need help! My Dad is a driving instructor and his teaching car is a 51 plate Clio 1.2 16v.

Only problem is... (Only!)

Rear lights. Indicators glow faintly when side lights on... flash when brakes pressed, when the hazard lights are on, they blink slowly, one, then the other, and it also flashes the brake lights...

Also, very occasionally it takes a good 5 minutes to start, and (unrelated) sort of "chugs" when driving. Changed the plugs, (after finding a socket!!!) seamed to sort chugging problem, for month or so. Only to return....

Also Dashboard lights flick in time to the indicators. Think this is mainly the fog light indicator. (But actual fog lights do not operate.)

And also just recently the radio, pips, then cuts out... not a major issue, but annoying.

PLEASE HELP! please? You can contact me on , or my father directly on

And help will be greatly appreciated!

littlepinkcabbages is offline  
  5 Lastest Threads by littlepinkcabbages
Thread Forum Last Poster Replies Views Last Post
Clio (2001) 1.2 16v electrical problems Electronics littlepinkcabbages 5 2634 8th November 2005 04:10 PM
For the best viewing experience please update your browser to Google Chrome