Renault Forums :: Independent Renault forum - View Single Post - Front top mounts, squint? Clio 2

View Single Post
post #1 of (permalink) Old 25th January 2007 Thread Starter
Junior Member
Join Date: Oct 2006
Posts: 14
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Front top mounts, squint? Clio 2

Hi there,

I'm new to this Clio business and i'm currently driving a Clio on a 2000 plate 1.9d van. I've been having a little bit of bother at higher speeds when I hit uneven ground. It almost feels like the rear of the car is lifting and wobbling!!

I get the feeling quite a lot but it was severe on a journey to Larnaca (i'm in Cyprus!), severe enough to stop and check the wheel wasn't coming off!

I jacked the car up and everything seems ok, apart from the front struts.

Firstly there is a gap (which closes when jacking) between the strut housing and the rubber mount. Is this normal?

Secondly the offside gap is actually a little squint, it slopes from left to right.

Not too sure if the problem is related or if it's meant to be like this? Any advice would be great!
Currently in KK's garage:
2000 Renault Clio II 1.2 BEAST
KK is offline  
  5 Lastest Threads by KK
Thread Forum Last Poster Replies Views Last Post
Renault Clio - Power steering pump renewal Engines cskinner001 8 12382 5th February 2007 08:23 AM
Green sensor on front of Clio 1.9d Engines KK 3 1117 26th January 2007 12:40 PM
Front top mounts, squint? Clio 2 Cars & motoring KK 3 1433 25th January 2007 12:28 PM
Smelly Clutch!! Engines robster 5 1527 11th October 2006 09:25 PM
Clio 2 - standard radio not working!! Electronics Williesmall 5 8590 10th October 2006 08:41 PM
For the best viewing experience please update your browser to Google Chrome