Renault Forums :: Independent Renault forum - View Single Post - Laguna Electrics Problem

View Single Post
post #1 of (permalink) Old 8th February 2007 Thread Starter
Junior Member
Join Date: Oct 2006
Posts: 14
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Laguna Electrics Problem

Hi ,

I have a 97 Laguna 2.2dt which has had intermittent electrical problems for a year or more. It can be fine for months and then one day the battery will be flat. Jump start and it's fine again. Now however, the probem is here to stay - it will be fine for a few days on a freshly charged battery but then the battery will go flat again. Just had the alternator replaced, but still have the problem. I occasionally get the battery and STOP lights coming on, or the ABS and SERV lights ?!

The last time it failed, it wouldn't even jump start. Am I looking at some kind of electrical drain, or a bad earth, or something else ? If anyone has had similar problems, I would be delighted to hear about it !


Currently in hughstary's garage:
1997 Laguna 2.2dt
hughstary is offline  
  5 Lastest Threads by hughstary
Thread Forum Last Poster Replies Views Last Post
Renault Laguna 1 - Clutch Judder Engines Lagdti 3 1432 15th October 2007 08:06 AM
Laguna Camshaft Pulley Engines thunderbird2 4 2707 3rd October 2007 08:11 AM
Renault Laguna 1 - Charging Problem Electronics mr espace 4 1563 28th September 2007 09:21 AM
Intermittent Electrical Problems - Laguna Mk 1 Electronics Lagdti 1 1027 18th June 2007 09:52 AM
Laguna Electrics Problem Electronics 4 1278 8th February 2007 09:29 AM
For the best viewing experience please update your browser to Google Chrome