Renault Forums :: Independent Renault forum - View Single Post - Renault Clio RT Immobiliser and Battery problems!

View Single Post
post #1 of (permalink) Old 8th February 2007 Thread Starter
Junior Member
Join Date: Jan 2007
Posts: 3
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Renault Clio RT Immobiliser and Battery problems!


Firstly, you will have to ignore my general ignorance with car problems as they really aren't my strong point - this may be quite long winded as a result.

Basically, I have had a problem with a leaky sunroof over the past 8 weeks or so. However, somehow I think it is sorted (although the recent snowfall may prove me wrong as it hasn't rained for a while). The water was leaking though through the little black box which houses the central locking and I think something to do with the immobiliser (told you I was ignorant!). So, that started fizzing after a while so we disconnected the fuse. Since it has all been put back together, the warning light for the immobiliser keeps flashing when the revs are low or when I slow down (looks like a heart monitor with orange wiggly light). More recently though, the battery keeps dying! Admittedly, I don't drive it that often but it is literally flat everytime I go to drive it - any idea why?

Appreciate it could simply be I need a new battery but just seems odd that it should happen at same time I get this warning light and have had a leaky sunroof!

Any help would be greatly received and appreciated! Also, any estimated costs to get it fixed would also be welcomed.

Thank you!
Currently in hanrahan66's garage:
Renault Clio 1.4RT
hanrahan66 is offline  
  5 Lastest Threads by hanrahan66
Thread Forum Last Poster Replies Views Last Post
Renault Clio RT Immobiliser and Battery problems! Electronics lankoss123 6 3482 8th February 2007 10:42 AM
For the best viewing experience please update your browser to Google Chrome