Renault Forums :: Independent Renault forum - View Single Post - Sat Nav doing strange things.

View Single Post
post #3 of (permalink) Old 8th February 2007
Diamond member
Eeeps's Avatar
Join Date: Oct 2006
Posts: 447
Nominated 0 Times in 1 Post
TOTW/F/M Award(s): 0
Thanks: 1
Thanked 28 Times in 27 Posts
Originally Posted by chrisray View Post
Hi everybody
Can anyone help me with this problem.
Just had the car serviced (90,000 It's a 03 Laguna 2 Initiale Sports Tourer 1.9 dci) also had the themostat replaced (heater is still rubbish) and n/s drive shaft replaced by a local garage not a Renault dealer.The morning after I picked It up from the garage the sat nav is no longer working.When I turn the sat nav on the position of the car is about 20 miles from the actual location according to the map.At first I thought the garage might have disconnected the battery for some reason and the system needed to be reset or somthing.However according to the garage the battery was not disconnected and I can't find anyway to do a reset anyway.Any help with this would be very much appreciated.
If the Sat Nav has lost its position then it can take up to 15 minutes to re-acquire.
What are the colours of the icons on the bottom centre of the display? One looks like a satellite dish, one a CD disk and the other shows TMC.

Currently in Eeeps's garage:
2011 Clio III dCi 88 Dynamique and 2016 CitroŽn Grand C4 Picasso Exclusive+ EAT6 2.0 BlueHDi
Eeeps is offline  
For the best viewing experience please update your browser to Google Chrome