2004 Megane erratic idle & over revving - Renault Forums :: Independent Renault forum

Engines Engines and other oily matters

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 14 (permalink) Old 18th June 2011 Thread Starter
Junior Member
 
Join Date: Dec 2010
Posts: 9
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 1
Thanked 0 Times in 0 Posts
2004 Megane erratic idle & over revving

Hi everyone. As the title says I have a problem with my wifes Megane over revving and erratic idle. I have took off the throttle boy and given it a clean, but noticed that the throttle itself doesnt close fully. How are these throttle bodies meant to be? I have put it all back together and it still has the same problem, but also noticed that if i manually turn the throttle with the tip of a screwdriver i can stop the erratic idle. It seems as if the motor on the opposite side isn't actually closing the throttle enough. Will this be the problem or is that how it is meant to be?

Kind regards

Mike
Currently in bloobloo's garage:
Renault Megane II, Mitsubishi Pajero, Renault Clio II
bloobloo is offline  
  5 Lastest Threads by bloobloo
Thread Forum Last Poster Replies Views Last Post
2004 Megane erratic idle & over revving Engines Twangster 13 18617 18th June 2011 08:59 PM
Clio II (y reg) hazard lights problem Electronics bloobloo 2 2337 15th December 2010 03:20 AM
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 18th June 2011
ourcar
Guest
 
Posts: n/a
Re: 2004 Megane erratic idle & over revving

I'd imagine it should not completely close or you would get no air to the TB.

If it is over revving, then it is getting too much air, check that there are no leaks prior to the TB.

It is possible that your MAP sensor is busted, worth getting checked.
post #3 of 14 (permalink) Old 21st June 2011 Thread Starter
Junior Member
Threadstarter
 
Join Date: Dec 2010
Posts: 9
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 1
Thanked 0 Times in 0 Posts
Re: 2004 Megane erratic idle & over revving

Quote:
Originally Posted by ourcar View Post
I'd imagine it should not completely close or you would get no air to the TB.

If it is over revving, then it is getting too much air, check that there are no leaks prior to the TB.

It is possible that your MAP sensor is busted, worth getting checked.

Hi, I have done a search over the last few days, looking for info on why my Megane is over revving and surging at idle.
Up to now I have found various posts but none that are the same prblem as mine, or that have been solved.
When the car is started, the car idles around 1600 - 1800 rpm, no misfires or any other problems. Once driven the car still idles at high revs, but also surges from 1000rpm upto 2800rpm.
So far I have removed and cleaned the throttle body , checked and improved the throttle body to manifold seal, tried a different MAP sensor , tried a different set of coil packs, checked for any other air leaks on the intake system. All to no avail.

I have ordered an ELM 327 diagnostics able and software to check any fault codes and that should arrive tomorrow, my galletto arrived today!

Any help greatly appreciated

Forgot to mention its a 2004 1.4 16v megane, 54,000 miles

Mike
bloobloo Posts: 2 Joined: Sat Jun 18, 2011 4:50 pm
Currently in bloobloo's garage:
Renault Megane II, Mitsubishi Pajero, Renault Clio II
bloobloo is offline  
post #4 of 14 (permalink) Old 21st June 2011
ourcar
Guest
 
Posts: n/a
Re: 2004 Megane erratic idle & over revving

Did you replace the seals that go between the upper and lower inlet manifold?
post #5 of 14 (permalink) Old 21st June 2011 Thread Starter
Junior Member
Threadstarter
 
Join Date: Dec 2010
Posts: 9
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 1
Thanked 0 Times in 0 Posts
Re: 2004 Megane erratic idle & over revving

No, I took out the seals and gave them a good clean. The first time i took it apart I used a gasket sealant but that made no improvement. I then went to the breakers yard and got another inlet manifold for 4.00 just in case the other one was cracked etc. I then took off the 1st inlet manifold, scraped and cleaned all the other gasket sealant off the lower inlet and replaced the top manifold. I will order new seals tomorrow and try that.
Currently in bloobloo's garage:
Renault Megane II, Mitsubishi Pajero, Renault Clio II
bloobloo is offline  
Reply

Tags
2004 , erratic , idle , megane , revving

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome