Engine management light flashing - losing power - Renault Forums :: Independent Renault forum

Engines Engines and other oily matters

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 17 (permalink) Old 7th December 2008 Thread Starter
Junior Member
 
Join Date: Dec 2008
Posts: 8
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Engine management light flashing - losing power

Hi, I have been driving my 2005 1.6 megane privilege for about 8 months now without any problems. I did have a couple of issues where the car would not start first time in the morning, but after a couple of attempts it was ok, and this was intermittent.

Today I was driving along a started to lose power and the engine management light started flashing. Can anyone give me some advice on what this might be?

I've read around and found it could be the engine coils , are these expensive to replace?

I'm going to take it to the garage tomorrow but hope someone may be able to give me a heads up as to the problem!?

Many thanks in advance!
Dan
Currently in gerrard_d's garage:
2005 Renault Megane 1.6 Privilege
gerrard_d is offline  
  5 Lastest Threads by gerrard_d
Thread Forum Last Poster Replies Views Last Post
Engine management light flashing - losing power Engines davidrowe 16 25770 7th December 2008 04:47 PM
Hi Welcome to RenaultForums Mike11 4 659 7th December 2008 04:41 PM
Sponsored Links
Advertisement
 
post #2 of 17 (permalink) Old 7th December 2008
Technical Supremo

 
Join Date: Feb 2007
Posts: 42,910
Nominated 16 Times in 67 Posts
Nominated TOTW/F/M Award(s): 28
Thanks: 368
Thanked 5,189 Times in 4,704 Posts
The two most common causes of poor running on Renault engines seems to be either duff coils or TDC sensors so it may well be worth getting those checked out first.

Keep us posted
Currently in madnoel10's garage:
Honda Civic 1.4l
madnoel10 is offline  
post #3 of 17 (permalink) Old 7th December 2008 Thread Starter
Junior Member
Threadstarter
 
Join Date: Dec 2008
Posts: 8
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by madnoel10 View Post
The two most common causes of poor running on Renault engines seems to be either duff coils or TDC sensors so it may well be worth getting those checked out first.

Keep us posted
Thanks for the response, how much would I be looking at to replace either of these from somewhere like nationwide autocenters?
Currently in gerrard_d's garage:
2005 Renault Megane 1.6 Privilege
gerrard_d is offline  
post #4 of 17 (permalink) Old 7th December 2008
Technical Supremo

 
Join Date: Feb 2007
Posts: 42,910
Nominated 16 Times in 67 Posts
Nominated TOTW/F/M Award(s): 28
Thanks: 368
Thanked 5,189 Times in 4,704 Posts
Depending on the quality each coil could start at around 15 plus each plus labour. If you find out its a coil problem try to identify which ones are duff and replace only them. Generally it only takes around 10 minutes or so for each coil and if you have the tools you could attempt it yourself. But find out the exact problem first
Currently in madnoel10's garage:
Honda Civic 1.4l

Last edited by madnoel10; 7th December 2008 at 05:19 PM.
madnoel10 is offline  
post #5 of 17 (permalink) Old 7th December 2008 Thread Starter
Junior Member
Threadstarter
 
Join Date: Dec 2008
Posts: 8
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by madnoel10 View Post
Depending on the quality each coil could start at around 25 each plus labour. If you find out its a coil problem try to identify which ones are duff and replace only them. Generally it only takes around 10 minutes or so for each coil and if you have the tools you could attempt it yourself. But find out the exact problem first
Absolutely no chance of me doing it myself!! I'd end up doing more damage!!!

I've been told its best to change them all, it this true, if so i'd be looking at 150ish??

Do these affect fuel consumption as well?
Currently in gerrard_d's garage:
2005 Renault Megane 1.6 Privilege
gerrard_d is offline  
Reply

Tags
engine , flashing , light , losing , management , power

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome