Renault Forums :: Independent Renault forum - View Single Post - Talking Computer

View Single Post
post #4 of (permalink) Old 17th February 2007
Platinum member
Horatio's Avatar
Join Date: Jul 2005
Posts: 6,475
Nominated 0 Times in 7 Posts
Nominated TOTW/F/M Award(s): 8
Thanks: 0
Thanked 95 Times in 64 Posts
Originally Posted by SportTourer View Post
Renault up to their old inconsistant tricks again!
That's probably me making assumptions again. The trip reset is missing on mine. I assumed it was the case with the earlier ones too.

Does the dash you're referring to show ' Oil OK' and let you see the tyre pressures while you're driving? If so, then it now looks like the Lag II has had at least three different instrument clusters throughout its lifespan. I don't know who the intermediate one was made by though. It'd be interesting to find out.

The Magnetti Marelli dash on mine shows their logo on the display if you go into instrument diagnostic mode (insert the card in the slot while holding down the button on the end of the wiper stalk.) I think the Sagem ones actually have 'Sagem' branding isible on the cluster itself, but I could be wrong.

I'm guessing they switched clusters after the number of problems with them irreversibly reverting to metric. Having said that, with Magnetti Marelli being a wholly owned subsidiary of Fiat, I'm not entirely filled with confidence.
Currently in Horatio's garage:
2010 Laguna III Initiale.

Last edited by Horatio; 17th February 2007 at 08:18 AM.
Horatio is offline  
For the best viewing experience please update your browser to Google Chrome