Renault Forums :: Independent Renault forum - View Single Post - Scenic 2 electric parking brake HELP!!

View Single Post
post #12 of (permalink) Old 25th February 2014
Veteran Member
Technical Supremo
Dancingdad's Avatar
Join Date: Dec 2013
Posts: 7,731
Nominated 27 Times in 25 Posts
Nominated TOTW/F/M Award(s): 8
Thanks: 964
Thanked 1,796 Times in 1,375 Posts
Re: Scenic 2 electric parking brake HELP!!

Originally Posted by andy-fish View Post
It may end up sounding a little confusing but here goes. When the ignition is turned on it says "check parking brake" when you start the car and release the brake by either the lever or by pulling away it says "parking brake fault" then, eventually, "parking brake off". Then it reverts back to "parking brake fault" for a while then goes away and all looks normal until you put it back on again. Then it says "parking brake fault" followed by "parking brake on" then back to "check parking brake" or "parking brake fault" depending upon what mood it's in.

Clear as mud!
Assuming the brake is working okay with no slipping or funny noises, I'd look to find a man with code reader to reset faults and see what comes up.
Could be system is doing what it is supposed to and telling you that there is a problem. Could be that it's got confused on settings and a reset will clear.
Could be an internal problem, problem with loom/connections, cables, calipers, pads or a sensor connected to the system.
Really guesswork without more concrete info.
Shop around. Doesnt have to be Renault dealers. Plenty of smaller places have can clips or other readers that can access system but ask first before you end up paying for something they can't do.
Currently in Dancingdad's garage:
Qashqai 1.6 spark driven, Kia Sedona 2.9 TDI, Scenic II 15DCi 2004 (SORN) not quite RIP.
Dancingdad is online now  
For the best viewing experience please update your browser to Google Chrome