Renault Forums :: Independent Renault forum - View Single Post - ABS Module/Pump

Thread: ABS Module/Pump
View Single Post
post #2 of (permalink) Old 8th March 2014
Platinum member
Technical Supremo
TTT's Avatar
Join Date: Jun 2008
Posts: 1,949
Nominated 3 Times in 7 Posts
Nominated TOTW/F/M Award(s): 4
Thanks: 197
Thanked 397 Times in 346 Posts
Re: ABS Module/Pump

I can only speak from the experience of ABS problems on my own car and a few other Laguna II owners that have had problems with their ABS.

Basically we have all fitted a 2nd hand ABS pump (Unit) and it has solved the problem.

I personally fitted the whole unit which involved disconnecting the brake pipes to the ABS unit but others have just fitted the ECU (Black box) part and it has solved their problems, I could have probably done the same as the fault seems to be within the ECU .

When sourcing a replacement make sure that the numbers on the unit match up and the unit is from the same vehicle.

Have a read through the thread in the link below for more info.

Laguna II - ABS not working but no warning lights ?


Please take the time to enter your vehicle details in the "What's current in your garage?" box.

To do this:
Hover over the "TOOLS" tab at the top of the page
> then in the dropdown click on "User Dashboard"
> click on "Edit Your Details" at the top Left hand side.
> scroll down to the "What's current in your garage?" box and enter your vehicle details.
> Once the details are entered scroll down to the bottom of the page and click "Save Changes"

> Done.
Currently in TTT's garage:
2001 Renault Laguna II 1.9dCi Dynamique Sport Tourer
TTT is offline  
The Following User Says Thank You to TTT For This Useful Post:
imwills (9th March 2014)
For the best viewing experience please update your browser to Google Chrome