Renault Forums :: Independent Renault forum - View Single Post - Renault Trafic - 2004 Wiper Fault*FIXED*

View Single Post
post #7 of (permalink) Old 10th March 2014
Junior Member
Join Date: Mar 2014
Posts: 1
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 1
Thanked 0 Times in 0 Posts
Smile Re: Trafic wipers not working properly

Originally Posted by fascia-man View Post
FIXED it today after reading thread about laguna wipers not working but having same symptoms the set up was similar but the problem was the same the contacts inside the gearbox on the end of the motor were gunked up plus 1 of them was snapped off (the earth 1) cleaned it up resoldered the broken 1 then strengthen it up with some epoxy put it all back together today and its fine have included a couple of pics
Thanks for the Tip on this and great fix by the way .... Just repaired broken contact on my wiper Motor just as you described on my 2009 Renault Traffic.
The Symptoms of my fault was that the wipers would not stop at the home position, they would just randomly stop in any position on the windscreen. At first the fault appeared to be something to do with the stork/switch on the steering column.
Since reading up on all of this I believe there is NO RELAY for the WIPERS and fiddling with the Stork/Pushing/forcing it away and towards the dash is only interrupting the the power somehow, and thus looking like there's a problem with it.
Also my central locking seems????? to by working more actively now too?? Hmmm
Currently in traffictad's garage:
2009 renault traffic high top
traffictad is offline  
For the best viewing experience please update your browser to Google Chrome