Renault Forums :: Independent Renault forum - View Single Post - Clio 2001 speed sensor

View Single Post
post #7 of (permalink) Old 8th March 2007
Still a Petrolhead but also like diesel
Truckbusuk's Avatar
Join Date: Apr 2006
Posts: 2,311
Nominated 0 Times in 2 Posts
Nominated TOTW/F/M Award(s): 2
Thanks: 0
Thanked 17 Times in 17 Posts
Hi gav and eric ... the speed sensor is a cheap option to check, rather than replace the cluster ... they are approx £25 from your friendly dealer.

WARNING ... check that the rubber sealing ring (its green if I remember correctly) is in place on the electrical connector as water in this connector will play havoc with the speedo output. There was also a Renault mod in 2001 that put a large plastic shield over the sender and the connector to prevent heat from the engine damaging the rubber seal and letting the water in .... it can be retro fitted and costs about a tenner.
Carefully clean the connectors with a spray-on electrical connector cleaner and careful use of a fibreglass pencil, that will clean out any veridgris and corrosion that may have accumuliated ... be careful as the pins in the sender are very fragile. ..... its easier to clean if you remove it first ... its just pulls out ... lube the bottom seals with engine oil before refitting.

hope it helps

Why is it the older I get .... the better I think I was ?
Currently in Truckbusuk's garage:
Clio2 1.4RT Phase1(VF1BB0S) + Volvo XC90 SE Lux D5 Geartronic

Last edited by Truckbusuk; 8th March 2007 at 09:19 PM.
Truckbusuk is offline  
For the best viewing experience please update your browser to Google Chrome