Renault Forums :: Independent Renault forum - View Single Post - Laguna I and major problems

View Single Post
post #1 of (permalink) Old 10th March 2007 Thread Starter
Junior Member
Join Date: Jun 2006
Posts: 10
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Question Laguna I and major problems

I wanted my laguna I 1.9 dti Alize checked out prior to the M.O.T. I took it to an independent garage first regarding am engine service but also rang a renault dealer to ask their price and to check a few things.

The independent could not even come close to matching the dealerships price, so I took it to them.

While it was there having a major engine service (310), I was called by the service manager who informed me of the following:

(1) both rear wheel cylinders had gone and that they were leaking and needed replacing and this would account for braking power loss (which I have not noticed); having since done a emergency stop the day after and the car stopped almost too well

(2) the near side CV joint rubber had split, no grease in there, that it had dried out and may last 2 days/2 weeks (but wouldn't it knock first?); drove the car to a place where there were some very tight turns with no knocking whatsoever

(3) that the whole handbrake assy had corroded and needed replacing; surely if it was corroded wouldn't the handbrake be slipping

(4) that the sub frame was badly corroded and would need replacing (he asked me over the phone - has this car been used or "lived" by the sea for a long period)? i have had a look at it today, it seems a bit rusty, and possibly corroded in one small corner but the under engine plastic panel is intact

I bought the car in aug 2006, it have been by the sea prior to being owned by me - we live in folkestone, it had a full M.O.T with the car and had had a full service prior to me buying it.

I took the car in for this full engine service - but the car feels worse than before (no go, sluggish). I also asked to look at the suspension because it sounded like it was knocking at low speeds, on the flat, in a straight line (suspension is fine). I also asked them to look at the drivers side window that comes out of it rubber when going up (they said they had sorted it, but it looks the same). I have taken the car out today and it does seem to be sluggish - certainly not as good uphill as it was

They do seem to taking the P big time. I have never heard of a subframe corroding in 6 years. I know sea air can take it's toll - but in a few months?

When I picked up the car today - i asked about the anti corrosion warranty and they informed me that it does not run out until 2008, but as it was on the job sheet it was assumed that they had checked that and that the subframe is not included.

Any thoughts people?
Currently in futsysmids's garage:
2000 renault laguna I 1.9dti Alize

Last edited by futsysmids; 11th March 2007 at 04:54 PM. Reason: Breaching name & shame policy
futsysmids is offline  
  5 Lastest Threads by futsysmids
Thread Forum Last Poster Replies Views Last Post
Laguna I and major problems Bodywork madnoel10 8 1822 10th March 2007 03:33 PM
laguna clutch & gearbox Transmissions Lagdti 3 1512 17th September 2006 11:30 AM
Laguna MK1 Fuse Panel Cars & motoring leroy 1 1856 8th September 2006 02:47 PM
Renault Laguna 2000 model Cars & motoring futsysmids 2 1151 10th August 2006 04:51 PM
Renault Laguna 2000 model Cars & motoring Horatio 1 1143 9th August 2006 09:34 PM
For the best viewing experience please update your browser to Google Chrome