MAF sensor - Renault Forums :: Independent Renault forum

Bodywork Paint care, corrossion, body kits, spoilers, skirts etc.

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 1st June 2012 Thread Starter
Junior Member
Join Date: May 2012
Posts: 5
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 1
Thanked 0 Times in 0 Posts
MAF sensor

I had a" fuel injection fault" come up on my screen .On investigation I found a broken wire going to the connector on the MAF sensor. When I repaired it the warning went back to the Renault sign but the car now seems to "hold back"when excellerate and then randomly seems to hesitate.I disconnected the wire again and the engine seems to run fine.So I can either haveno warning and a rough engine or a warning and a smooth engine. Could the sensor be faulty? Any ideas?
Currently in lagunalover's garage:
2002 laguna 1.9dci
lagunalover is offline  
  5 Lastest Threads by lagunalover
Thread Forum Last Poster Replies Views Last Post
MAF sensor Bodywork lagunalover 0 831 1st June 2012 06:54 PM
Relay location/fuse? Electronics lagunalover 2 1203 1st June 2012 06:45 PM

maf , sensor

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome