s**t washer jets - Page 2 - Renault Forums :: Independent Renault forum

Bodywork Paint care, corrossion, body kits, spoilers, skirts etc.

LinkBack Thread Tools Display Modes
post #6 of 14 (permalink) Old 14th February 2008
Technical Supremo

Join Date: Feb 2007
Posts: 42,935
Nominated 16 Times in 67 Posts
Nominated TOTW/F/M Award(s): 28
Thanks: 371
Thanked 5,199 Times in 4,711 Posts
Try unblocking the jets using a hair pulled out of a wire brush - could also be the impeller on the pump is worn. On some models there is only one pump so both front and rears will be affected.
Currently in madnoel10's garage:
Honda Civic 1.4l
madnoel10 is offline  
Sponsored Links
post #7 of 14 (permalink) Old 14th February 2008 Thread Starter
Platinum member
daft_plonk's Avatar
Join Date: Nov 2007
Posts: 4,955
Nominated 0 Times in 1 Post
Nominated TOTW/F/M Award(s): 3
Thanks: 0
Thanked 5 Times in 3 Posts
ill try that and i recon i only have one pump. the problem with the back is that there is actually no little tube sticking out of the housing
Currently in daft_plonk's garage:
2003 Honda Civic Inspire S 1.6 Vtec
daft_plonk is offline  
post #8 of 14 (permalink) Old 14th February 2008
Platinum member
Bob925's Avatar
Join Date: Aug 2007
Posts: 8,274
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 2
Thanked 16 Times in 14 Posts
Also I think they changed the rear jet design between the Ph1 and Ph2 cars. I don't know how to take either off though

Agreed though, the front ones are carp! I'm forever having to adjust the jets up but they keep auto-aiming for the centre of the earth

The Vauxhall Cavalier - one of the safest cars you'll bump into
Currently in Bob925's garage:
2015 '65 Vauxhall Astra SRi, and a variety of "lovely" buses
Bob925 is offline  
post #9 of 14 (permalink) Old 14th February 2008
Platinum member
Join Date: Dec 2007
Posts: 1,965
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 3 Times in 3 Posts
Thats strange. Our front ones never change the height they aim at, but the direction!

I'm always having to bring them back from the left towards the right!!! Very annoying...
Currently in delta1066's garage:
delta1066 is offline  
post #10 of 14 (permalink) Old 14th February 2008
Platinum member
superbiatch's Avatar
Join Date: Nov 2005
Posts: 9,793
Nominated 0 Times in 1 Post
Nominated TOTW/F/M Award(s): 2
Thanks: 5
Thanked 7 Times in 7 Posts
Originally Posted by daft_plonk View Post
no the pump sounds ok when i press the button, just not that much pressure in the water flow :S.
Mine sounded fine as well, but upon changing the pump (tried every other possibility), the washers started working. If you can't find a blockage, you'd be best just to pick up a new pump (they are surprisingly cheap)
Currently in superbiatch's garage:
57 reg 1.6 tdci Fiesta Zetec Climate
superbiatch is offline  

jets , washer

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome