Cracking noise when opening/closing doors - Page 3 - Renault Forums :: Independent Renault forum

Bodywork Paint care, corrossion, body kits, spoilers, skirts etc.

LinkBack Thread Tools Display Modes
post #11 of 11 (permalink) Old 15th July 2015
Technical Supremo

Join Date: Feb 2007
Posts: 42,935
Nominated 16 Times in 67 Posts
Nominated TOTW/F/M Award(s): 28
Thanks: 371
Thanked 5,199 Times in 4,711 Posts
Re: Cracking noise when opening/closing doors

Originally Posted by Adam135 View Post
I was just going to ask the same question regarding the door hinge on my 2012 megane 5 door. My thoughts were to wd40 and then follow up with some spray lithium grease. Does this sound like it would work?
Spray lithium grease is ideal but also more expensive. I rarely use WD40 as it is primarily a water dispersant rather then a corrosion releasing agent. I tend to use "DD" brand releasing fluid which comes with it's own pipe extension.
I use WD40 for drying wet electrics and protecting tools such as saws before putting them inro storage.
Currently in madnoel10's garage:
Honda Civic 1.4l
madnoel10 is offline  
Sponsored Links

cracking , doors , noise , opening or closing

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome