Ren Clio Wiper Cover - Page 2 - Renault Forums :: Independent Renault forum

Bodywork Paint care, corrossion, body kits, spoilers, skirts etc.

LinkBack Thread Tools Display Modes
post #6 of 7 (permalink) Old 24th July 2006
Platinum member
superbiatch's Avatar
Join Date: Nov 2005
Posts: 9,793
Nominated 0 Times in 1 Post
Nominated TOTW/F/M Award(s): 2
Thanks: 5
Thanked 7 Times in 7 Posts
Originally Posted by chris m
not sure but I need one and so do a couple of my neighbours if you find any
Me too! Was yours lost at the car wash?? Yet another design fault on renault's possibly?
Currently in superbiatch's garage:
57 reg 1.6 tdci Fiesta Zetec Climate
superbiatch is offline  
Sponsored Links
post #7 of 7 (permalink) Old 25th July 2006 Thread Starter
Join Date: Jul 2006
Posts: 72
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Not to sure where lost it,need one cheeeep ! ! ! !
Currently in LEEDASH's garage:
LEEDASH is offline  

clio , cover , ren , wiper

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome