Renault Forums :: Independent Renault forum - View Single Post - Vel Satis Problems

View Single Post
post #24 of (permalink) Old 12th March 2007
jamesyboy5593's Avatar
Join Date: Mar 2007
Posts: 85
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 2 Times in 1 Post
Hello again everyone.

Well I did but the Vel for £5000 with the sat nav not working. I was prepared to pay £6000 (the original agreed price with everything working) so I still have a grand to get the satnav/stereo working myself. Gonna just take it straight into local dealer for a test to see whats wrong and take it from there.

However apart from a small ding one the rear wheel arch everything external is tip top including wheels. The interior is very good just a bit grubby where mechanics been in and out, nothing a good valet wont sort out. The area around the drivers seat shows numerous scratches and a bit more wear and tear as to be expected from 111000 miles but everywher else is imaculate. It looks like the boot was never used neither has the spera wheel and jack ever left the boot. So it would seem this was and exec m/way cruiser rather than a family car. Its has every service including the cambelt so i'm well happy.

If the sat/nav can be fixed cheap i'll be even happier!!!

Let you know how it goes.
Currently in jamesyboy5593's garage:
Scenic II 1.9DCi Privilege, Fiat Coupe 20v Turbo, VW Eos 2.0 TFSI DSG, Gilera Nexus 500 scooter.
jamesyboy5593 is offline  
For the best viewing experience please update your browser to Google Chrome