Renault Forums :: Independent Renault forum - View Single Post - Electrical Gremlins

View Single Post
post #1 of (permalink) Old 12th March 2007 Thread Starter
Junior Member
Join Date: Mar 2007
Posts: 5
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Electrical Gremlins

This is my first post, so hello to all

I have had my clio 1.2 16v mk 3 Extreme for a short while and lately I have had some weird electrical problems in the last 2 weeks.....

1. One day the horn didnt work all day and then worked the next.

2. The electrical fault light lights up every now and then, and once when it was lit and the engine was running, the accelerator didnt respond when fully depressed!!

3. On another occasion when I turned the ignition on, all the lights lit up as usual but the engine didnt turn over/start. 10 minutes later I tried again (umteeenth time) then it started!!

I love my clio but Im really worried what the problem maybe or what this could cost me.

Please please could someone shed some light on this matter
Currently in lebel's garage:
clio 1.2 16v mk 3 Extreme
lebel is offline  
  5 Lastest Threads by lebel
Thread Forum Last Poster Replies Views Last Post
stalk switch assembly Cars & motoring Truckbusuk 1 762 20th May 2007 03:22 PM
Please recommend a specialist Clio tsunami 3 1128 13th March 2007 04:29 PM
Electrical Gremlins Clio lebel 3 2116 12th March 2007 07:14 PM
For the best viewing experience please update your browser to Google Chrome