Renault Forums :: Independent Renault forum - View Single Post - Demister / AC Panel + Fuse Box Nightmare

View Single Post
post #4 of (permalink) Old 17th March 2007
Platinum member
TazzyK's Avatar
Join Date: Mar 2006
Posts: 1,076
Nominated 0 Times in 4 Posts
Nominated TOTW/F/M Award(s): 2
Thanks: 30
Thanked 73 Times in 63 Posts
If the only thing that is faulty is the rear heater now, then I think the garage probably removed the relay which is why it isn't clicking anymore, or they removed it and put it back but never pushed it in properly.... does the light on the button still light up?

The rear heater not working on the Laguna's is a very common problem.... and easy to sort out providing you haven't burnt anything else.

Firstly, make sure the relay is in there. The relays are underneath the fuse box under another cover if I remember correctly. There are a few relays there, all sort of a lilac colour. Make sure they are all plugged in firmly. There will be a few empty spaces and chances are that the relay was removed and not put back in.... the hardest part will be to guess which relay is for what as they are not marked.

Swap the relays around with another lilac one as they are the same until you get a 'click' when operating the rear heater switch.

Once you get that far, the rest is easy (hopefully).... In the luggage compartment, on the passenger side, lower the trim (where the light for the luggage compartment is) and you should see a white connector box with loads of wires. The heater wire feeds into this block and then goes to the screen. It's one of the THICK wires, which you need to test for. For some reason, the connection does not pass through to the other side, so, if there is power going into the block, you need to bypass the plug and connect the wire directly to the wire on the other side of the block going out and hey presto.... you'll have a working heater again.

I hope you haven't blown anythiung in the fuse box.... I did that once... not too easy to replace!

Oh, and this is based on my 1997 1.8 Laguna, so it may be slighlty different but should be more or less the same
Currently in TazzyK's garage:
Renault Clio 1.4 16v Privilege (2004), Renault Megane 1.5 dCi 106 Expression (2005), Volkswagon Passat 2.0 TDi S (2006), Alfa Romeo 159 2.4 JTDm QTronic Lusso (2008)

Last edited by TazzyK; 17th March 2007 at 09:42 PM.
TazzyK is offline  
For the best viewing experience please update your browser to Google Chrome