Renault Forums :: Independent Renault forum - View Single Post - Clio - Heater not woking!

View Single Post
post #1 of (permalink) Old 22nd March 2007 Thread Starter
Junior Member
Join Date: Mar 2007
Posts: 8
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Clio - Heater not woking!

Hi all,

I've just signed up to this excellent forum site where Renault car owners can discuss issues and help one another with their problems.

I bought a M reg Renault Clio RN, MK1, 1.2L last year and when winter had arrived, I had my car serviced and had the water/coolant changed with new anti-freeze put in. I had this done by a local garage person and he couldn't find a bleeder on the car and had to maually bleed the air out himself and everything was in working order i.e. the fan does come on. I then drove my car for a while and noticed no hot/warm air was coming into to my car. It comes for about 3 seconds and the disappears again and returns to cold air!

I would reallyt like to ask what my main gripe is here??! Where is the bleeder and do the MK1 Clio's have a bleeder?
Is there a problem with my matrix? I have been advised to use radflush?!

Please help as it's freezing in my car!!!!!!
Currently in Abdul786's garage:
Renault Clio RN, 1.2L
Abdul786 is offline  
  5 Lastest Threads by Abdul786
Thread Forum Last Poster Replies Views Last Post
How do you sort out the rusting? Bodywork madnoel10 6 1547 25th March 2007 10:39 PM
Clio - Heater not woking! Clio davieclio86 10 7994 22nd March 2007 11:44 PM
No heat in my car! Heating & cooling chris m 9 2467 22nd March 2007 11:43 PM
For the best viewing experience please update your browser to Google Chrome