Renault Forums :: Independent Renault forum - View Single Post - Electronic handbrake stuck on during MOT and won't release

View Single Post
post #5 of (permalink) Old 12th April 2014 Thread Starter
Junior Member
Join Date: Feb 2011
Posts: 16
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 1
Thanked 0 Times in 0 Posts
Re: Electronic handbrake stuck on during MOT and won't release

Originally Posted by Dancingdad View Post
Personally I'd have a go at the garage.... if front wheels turn when handbrake is on, the handbrake applies more power to stop the car rolling.
And it sounds like it's managed to jam itself up.

I'd suspect either mechanical jam or electonics inside the unit burnt out.
Take a looksee in the stickies, there are a couple of threads with strip down photos.

The emergency release is a mechanical release that lets a pawl in the unit release the cables.
If there is a mechanical jam, it may not release both sides as it relies on tension to operate... pulling it when the handbrake is off does nothing for example.

I think that you are going to have to drop the box from under the back axle and open it...torx screws on the one side after you remove the carrier. That will give you chance to have a look.
My wife wants to blame the garage, and normally I would agree, but surely the garage use the same procedure week in week out on electronic brake-equipped cars- front wheels on roller, handbrake on, up to speed and brake. Do you think they did something wrong- perhaps the car should be strapped down instead of using handbrake? I'm very interested to know if the garage ballsed up, perhaps a call to Renault on Monday to ask about the correct mot procedure.

I opened the box today and looks OK, no tell tale black marks on the pcb, both left and right mechanicals move smoothly, mechanical release disengages well.
Currently in kpm197's garage:
Clio 172 Cup
kpm197 is offline  
For the best viewing experience please update your browser to Google Chrome