Renault Forums :: Independent Renault forum - View Single Post - ABS Relay Laguna Sports dti 2000

View Single Post
post #6 of (permalink) Old 27th March 2007
Junior Member
Join Date: Jan 2007
Posts: 12
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Hi (posted this in electronics section)

My abs stopped working a few weeks ago and had STOP,SERV,Handbrake and ABS lights on.

I have spend the last two weeks searching for information on the system and how to fix it.

After paying a garage 45 for codes to be read, they said power relay fault and would probably need new unit at 500 plus labour.....not likely as the cars only worth 1.5k at best.

I took the ABS controller out (Teves MK20i), easier than it looks and spent the last week fixing it. You can still drive without the abs ECU as the brake circuit is sealed.

Took me 1 day to get inside the thing (well sealed), not a power relay in sight (all done with power mosfets). Found the fault easy, bad connection on power pins, resoldered all connections and the stop light went out on the bench but still had abs light.

After a week of searching for info on reading codes from it, found out that all you have to do is simulate driving above 12 mph and the damn light went out.

So in conclusion :-


Power fault on pins 3 or 4 or blown fuse F18/F24.


Bad connection at abs ECU on multiplug ( bugger to disconnect )

ABS/SERV lights can be lots of different problems :-

Fuse F9/F10 blown or bad connection (these are 30A in the engine comp)

Wheel sensor open circuit/dirty

Pump open circuit

Solenoid open circuit (can only be checked by opening ecu )

Internal track fault as mine was (again, can only be found by opening)

When you have the unit disconnected, quite easy to check some of above and find the probable cause.

Hope this helps someone else avoid costly rip off......
Currently in stevedrink's garage:
2000 Laguna I 1.9DTi
stevedrink is offline  
For the best viewing experience please update your browser to Google Chrome