Renault Forums :: Independent Renault forum - View Single Post - Clio new front brakes binding

View Single Post
post #1 of (permalink) Old 22nd April 2014 Thread Starter
Junior Member
Join Date: Apr 2014
Posts: 2
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Clio new front brakes binding

I just put some new discs and pads on my partners 53 Clio today but the new pads were binding and caused the brakes to start smoking/steaming after driving for only a mile (if that)

I took them apart again and did the bolts in the guide pins a little less tight this time and that seems to of helped a bit as they didn't seem to get hot after making the same trip again. The guide pins are well lubricated on both carriers and move about freely.

When I put the new pads on, I backed the piston fully off but they start binding a little bit before I even pressed the pedal. So I don't think it's anything to do with the piston not retracting when you take your foot off the pedal.

Brake fluid is below the max even with the pistons fully compressed and the new pads are seated correctly. I cleaned a lot of the dust etc from the caliper and it's carrier.

Are they supposed to be like this until they "bed in"? It's the same story on both sides of the car.
theclioguy1 is offline  
  5 Lastest Threads by theclioguy1
Thread Forum Last Poster Replies Views Last Post
Clio new front brakes binding Brakes/Hubs theclioguy1 3 1044 22nd April 2014 05:55 PM
For the best viewing experience please update your browser to Google Chrome