Renault Forums :: Independent Renault forum - View Single Post - Seriously bad vibrations...

View Single Post
post #1 of (permalink) Old 12th May 2014 Thread Starter
Junior Member
Join Date: May 2014
Posts: 23
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 6
Thanked 2 Times in 2 Posts
Exclamation Seriously bad vibrations...

Hello fellow Renault Forums guys and girls,

Have had a look around and not a lot of clear answers about , so i'm hoping that being a newbie here I might be able to contribute as much as I require help this time round! The garages cant help until next week and its driving me mad!

Bought a Renault Megane 1.9 DCi in the gorgeous blue with 3 doors! not that long ago, since then she's had four new boots and some lovely xenon bulbs inside and out courtesy of Redline! (Will post pictures).

Big problem thats driving me insane - When driving and applying the brakes from above 50mph, sometimes lower the is a severe shake from the passenger side front wheel. It is accompanied by a nasty knock with it. I dont believe its the brake discs and pads because it feels nothing like the brakes are knocking. It seems to be more the suspension components or the steering components.

Has anyone else had this?
I believe the discs and pads are fine
the wheels have been balanced and steer straight without knocking whilst driving

My guesses are that its the
inner track rods (the gaiter has come loose on the passenger side)
Track rod ends (but seem to be fine)
Shock absorber (bigger job but the garage is taking ages - no way of knowing which is which)

Any ideas I would really appreciate! Would love to stick two fingers up to the garages who want to take until next week!
Currently in Adam10's garage:
2.0 GT DCi 150
Adam10 is offline  
  5 Lastest Threads by Adam10
Thread Forum Last Poster Replies Views Last Post
Seriously bad vibrations... Brakes/Hubs HeatherJ 22 2925 12th May 2014 01:16 PM
For the best viewing experience please update your browser to Google Chrome