Renault Forums :: Independent Renault forum - View Single Post - Renault Scenic - Sticking Accelerator Pedal*fixed*

View Single Post
post #2 of (permalink) Old 5th April 2007
S.M.A.R.T.(y) Pants
VelSatisfied's Avatar
Join Date: Jul 2006
Posts: 16,938
Nominated 11 Times in 37 Posts
Nominated TOTW/F/M Award(s): 17
Thanks: 4,551
Thanked 2,471 Times in 1,852 Posts
Hi Rupert, and welcome to the forums.

A perplexing one, that's for sure.

Either the recent work is entirely unrelated and its pure coincidence (which can happen), or its something caused by the garage (which is where I think you believe the responsibility lies ).

I'm fairly sure your car will have a cable-operated throttle (rather than drive by wire), so I'd be inclined to trace the throttle cable from the pedal box, through the bulkhead to the engine, and look for signs of fraying, dirt, bends or twists which would impede its operation.

Also, if the cable is sited (or has been moved) close to a heat source (i.e. engine or exhaust manifold), then this can cause the cable to 'stick' within the sheath.

I'd also make my disatisfaction known to the garage (politely, but firmly).

Hope this has helped,


This job should never be complete - the day I think I've done it all, is the day I resign.

S.M.A.R.T. Technician
Currently in VelSatisfied's garage:
2005 FIAT Ducato 2.8JTD LWB Gran Volume, 2000 Kawasaki ZZR 1100 D7 'fullpower' in black + full GIVI & KAPPA luggage, 2007 MB R-Class 320 CDi Sport LWB uprated by Brabus to 300Bhp don't know if there's a 155mph limiter - will be fun finding out! 2004 Mercedes Vaneo 1.7 CDi Ambiente 7-seater
VelSatisfied is offline  
For the best viewing experience please update your browser to Google Chrome