Renault Forums :: Independent Renault forum - View Single Post - New megane owner from Kettering -few problems

View Single Post
post #1 of (permalink) Old 18th May 2014 Thread Starter
Junior Member
Join Date: May 2014
Posts: 2
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
New megane owner from Kettering -few problems

Hi all

I picked up a 54 plate megane on Tuesday. Got it privately. Test drive it and all ok. Parted with £750

Anyway this Friday while driving (about 20mph) I lost power for about 5 seconds. Put my foot on the accelerator and the problem went away.

Thought I would pull over into a local kiwi-fit and they said to do a battery test.

It was free so they did it. They said my battery was 64% unserviceable but the alternator was fine. They also said the battery was not the correct one for the car. They waned £87 for a new battery.

Anyway left the garage and noticed the service light was on, also the light that looks like an engine was on and in the centre it said "check injector"

My mate then got his obd2 reader out and found out the following:


I think 2 errors are for the O2 sensors and 1 is from the cam shaft sensor.

We cleared them but the minute the car was started the lights came back and when retested it showed the same errors.

Rang renault in Kettering and they said the battery would £55 from them without gutting, and also it may clear the errors.

Anyway bought the battery and it turns out the one in the car is more powerful then the battery supplied by renault.

Any ideas if replacing the O2 sensors will fix the problem? My mate said chances are it will come back even when replaced. He did say the cam sensor may fix itself as it may have not got the correct voltage from the battery.

I did find a receipt in the glove box to say a pulley had been replaced.

Part from that the car is great to drive.

Can anyone help me and point me in the right direction to fix these issues, or should I cut my losses.

Currently in namrood's garage:
Megane Mk2 1.6VVT
namrood is offline  
  5 Lastest Threads by namrood
Thread Forum Last Poster Replies Views Last Post
Start button colour change... Is it possible? Interior styling daznkel 2 2308 21st May 2014 11:00 PM
New megane owner from Kettering -few problems Cars & motoring namrood 0 414 18th May 2014 10:39 PM
For the best viewing experience please update your browser to Google Chrome