Renault Forums :: Independent Renault forum - View Single Post - Seriously bad vibrations...

View Single Post
post #16 of (permalink) Old 20th May 2014 Thread Starter
Junior Member
Join Date: May 2014
Posts: 23
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 6
Thanked 2 Times in 2 Posts
Exclamation Re: Seriously bad vibrations...

Right so this is my thinking at the moment - a list of parts and a process of elimination - let me know your thoughts!

Wheel Bearing - Wheels arent grinding or making any noise whilst in motion

Discs - possibility but unlikely as the car doesnt struggle to accelerate.

pads - same as discs, they arent biting

Shocks - Could be - the gaiter is split. unsure if it would give these symptoms.

Springs - could be - they dont look damaged although on the passenger side theres a bit of almost loose plastic underneath the spring and inbetween the bottom of the shock where the spring sits...a plastic lining or something?

Top mounts - not much in the way of grinding whilst steering so I dont believe so.

Steering rack - well the mechanic did report that the rack had play in it but not enough to make the left side go sloppy.

Wishbone - It could be...likely though? the ball joints are almost new.

Anti roll bar bush - I dont understand the ARB set up on the Megane, my old Saxo was a lot simpler! drop links need replacing or tightening up? they look original...

Lower ball joint - see wishbone clause

CV Joints - I thought a failed ball joint was a situation where the boot split and is a constant gring almost?

Power steering pump - suggested by Halfrauds when they did the tracking (Badly and still having issues as a result)

Let me know what you think guys, this is driving me nuts and the garages both take an age and arent giving the info I want to decide what is what!
Currently in Adam10's garage:
2.0 GT DCi 150
Adam10 is offline  
For the best viewing experience please update your browser to Google Chrome