Renault Forums :: Independent Renault forum - View Single Post - Megane ABS, STOP, Service and handbrakelights

View Single Post
post #1 of (permalink) Old 24th May 2014 Thread Starter
Junior Member
Join Date: Jul 2013
Posts: 3
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Megane ABS, STOP, Service and handbrakelights

Have replaced</SPAN> control arms, tie rods, CV joints and wheelbearings on my Megane. When all this was done a strange problem appeared. At 80-90 km / h (engine braking coming down from higher speed) the instrument panel beeps and</SPAN> ABS, STOP, Handbrake and service lights come on. Almost at the same speed every time. ABS function falls completely away. When i turn off the car and start again everything gets back to normal and the ABS works fine. Have gone through every single ABS sensor around the car with thorough cleaning. Around the same time that I changed all the parts i also fixed the handbrake. The wires had dropped out in the center console. I removed the brake calipers and went through them. Has anyone on the forum encountered similar problems and is there an ingenious solution? Grateful for any help.</SPAN>
Currently in javelinx's garage:
2003 Renault Laguna II 2.0 T
javelinx is offline  
  5 Lastest Threads by javelinx
Thread Forum Last Poster Replies Views Last Post
Megane ABS, STOP, Service and handbrakelights Brakes/Hubs javelinx 0 622 24th May 2014 07:57 AM
Speedometer and more Electronics Ralph 3 770 11th May 2014 08:12 AM
For the best viewing experience please update your browser to Google Chrome