Renault Forums :: Independent Renault forum - View Single Post - Renault Espace Problems

View Single Post
post #7 of (permalink) Old 10th April 2007
Junior Member
Join Date: Apr 2007
Posts: 1
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
I have experienced similar problems with the airbag error. Also the lighting at the back of the speedo display.

With regard to the lighting, my problem is that the wiring circuit printed onto the plastic sheet has a break, causing the lights to work intermittently. I have tried to fix it with some foil, but this failed pretty quickly. I intent to use some paint that conducts electricity (as used on heated rear windscreens) to try again when I have the energy.

It's difficult to get at this bit. You need to carefully remove the grilles over the front speakers. Remove the speakers with a tork key. Them remove the large plastic trim. There are foam pads to hold things in place. These have sticky bits that make first removal tricky. The speedo box is now on display. There are 3 tork screws (small) to remove before you can get at the bulbs etc. It's best to change all bulbs when you get in here as you don't want to have to do it again too quickly. Us a AVO meter to see if you a similar problem to me - set it at 12v and move around to circuit to see where you have voltage. Good luck!
Currently in microbe's garage:
Espace III RXE V6
microbe is offline  
For the best viewing experience please update your browser to Google Chrome