Renault Forums :: Independent Renault forum - View Single Post - 1998 8v 2ltr RXE Scenic coldstart issue

View Single Post
post #1 of (permalink) Old 18th April 2007 Thread Starter
chris scenic
Junior Member
Join Date: Apr 2007
Posts: 12
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Question 1998 8v 2ltr RXE Scenic coldstart issue

Hi all,
my scenic has got cold start issues, did have more going on but an Idle Control Valve seems to have cured it.
On cold start, it will catch and rough idle but wont rev for a few mins without stalling. After it has caught proper it will run but splutter when the clutch is released. When this clears the car will run all day and can be restarted without issue. It only happens after a full night cooling down.

Is it the cold start sensor? If so where and what colour is it?
Or could it be the MAP sensor , again which one and where?
And any ideas of an online shop that will stock reasonably priced sensors?

The motor also has an issue with the instruments (just temp and fuel) they behave like they have a bad earth so are reluctant to deflect, then (after a couple of miles) read correctly (simultaneously). Ive had the dash to pieces and found little wrong but cant locate the earth.

can anyone help a Renault virgin please?

Currently in chris scenic's garage:
1998 renault megane scenic 2.0 RXE
chris scenic is offline  
  5 Lastest Threads by chris scenic
Thread Forum Last Poster Replies Views Last Post
1998 8v 2ltr RXE Scenic coldstart issue Electronics chris m 3 1078 18th April 2007 06:36 PM
Scenic1 20 RXE Idle Issues! Engines chris scenic 2 954 3rd April 2007 12:14 PM
For the best viewing experience please update your browser to Google Chrome