Lag II Flashing battery light - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 22nd December 2006 Thread Starter
Junior Member
Join Date: Nov 2006
Posts: 1
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Lag II Flashing battery light

I have had the Laguna II 1.9 dci (2001) estate just over 18 months now, and touch wood, nothing major to report. However this morning, temperature reading of -4 degrees, I had the STOP and BATTERY lights flashing on the dahsboard.
I believe the problem is alternator related and would appreciate if some-one can confirm or has had a similar problem.

I have also noticed the fan blower is quieter and less responsive than normal and the electric windows are not moving as smoothly.

Currently in species4's garage:
2001 Renault Laguna II 1.9dCi
species4 is offline  
  5 Lastest Threads by species4
Thread Forum Last Poster Replies Views Last Post
Lag II Flashing battery light Electronics gordonpringle 2 1093 22nd December 2006 07:34 AM
Sponsored Links
post #2 of 3 (permalink) Old 22nd December 2006
Let's be carefull out there
chris m's Avatar
Join Date: Jan 2006
Posts: 19,344
Nominated 1 Time in 1 Post
Nominated TOTW/F/M Award(s): 3
Thanks: 3
Thanked 32 Times in 32 Posts
Send a message via MSN to chris m
welcome to the forums. it sounds as if the battery is struggling in the cold. Try giving it a long run or taking it out and charging it. If all else fails replace it as at 5 years old it's getting on and may have lost it's capacity to retain charge.
Currently in chris m's garage:
2000 Scenic 2.0 16v Monaco, BMW 3 Series, Pug 206
chris m is offline  
post #3 of 3 (permalink) Old 22nd December 2006
Join Date: Dec 2006
Posts: 63
Nominated 0 Times in 1 Post
Nominated TOTW/F/M Award(s): 1
Thanks: 3
Thanked 1 Time in 1 Post
If you have access to a multimeter of some kind check the battery voltage with the engine running at a fast idle or just above it should show about 13.5 to 14 volts if it shows much less there's a good chance you have an alternator problem. When mine played up it needed brushes but guess what... not available exchange alternator was the only option! Gone are the days when a £3 or £4 brush set fixed it.
Hope this helps.
Currently in gordonpringle's garage:
espace mk3 2.2 dti, renault 17TS, renault 17ts11, renault scenic 1.9 tdi, renault scenic 1.4 16v, renault clio 1.5 dci
gordonpringle is offline  

battery , flashing , lag , light

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome