renault problem - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 26th December 2006 Thread Starter
Junior Member
Join Date: Dec 2006
Posts: 2
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
renault problem

Hi.I have a problem with my tuner list cassette player in my 2000 scenic.It seems to turn on and off.By which i meen,the button lights illuminate and the buttons beep.I also have a problem with the radio display unit,It only displays time and temp.The rest is blank,Could the two problems be connected or are they seperate problems.Please help.Its driving me mad.Thanks
Currently in flippmo's garage:
2000 scenic 1.4
flippmo is offline  
  5 Lastest Threads by flippmo
Thread Forum Last Poster Replies Views Last Post
renault problem Electronics price5 3 2311 26th December 2006 07:54 AM
Sponsored Links
post #2 of 4 (permalink) Old 26th December 2006
Let's be carefull out there
chris m's Avatar
Join Date: Jan 2006
Posts: 19,344
Nominated 1 Time in 1 Post
Nominated TOTW/F/M Award(s): 3
Thanks: 3
Thanked 32 Times in 32 Posts
Send a message via MSN to chris m
has the battery been disconnected. You may need to re enter the radio code.
Currently in chris m's garage:
2000 Scenic 2.0 16v Monaco, BMW 3 Series, Pug 206
chris m is offline  
post #3 of 4 (permalink) Old 1st January 2007
Join Date: Dec 2006
Posts: 65
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
well yeah they are related. The display doesn't show anything when the radio is off.

I find the stereo in our megane takes time to come on. press the button and wait 5 or so seconds.

When we first got it about 3 weeks ago, I'd press the button, then press again and again and again - thought it was broken
Currently in scottc's garage:
'97 Megane 1.6
scottc is offline  
post #4 of 4 (permalink) Old 12th July 2007
Junior Member
Join Date: Jul 2007
Posts: 1
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
renault problem

Have'nt got an answer to this but your not the only one with this problem !!! My display is illuminated from the back as I have changed both bulbs but only the LCD for clock and temp are visible radio is big illuminated orange blank even with the radio turned on.

Nothing to do with needing to re enter radio code as you can't see the numbers in order to select them anyway.

I suspect my unit is knackered so am looking to replace, if it works will let you know.
Currently in price5's garage:
1999 Renault Megane Scenic 1.6 Sport Alize
price5 is offline  

problem , renault , scenicradio

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome